LexBlog Phone and Internet currently out of service
Incident Report for LexBlog
Resolved
LexBlog phone service has been restored.
Posted Jun 15, 2016 - 16:22 PDT
Identified
We have restored internet but phones are still out of service. Members, please continue to utilize email and our ticketing form to reach our team at this time.
Posted Jun 15, 2016 - 10:00 PDT
Investigating
Our phone and internet is currently out of order at LexBlog Seattle headquarters.

Note: there is no impact to blog service or availability as a result of this incident.

While we work to restore service, please contact us via our ticketing form at LexBlog.com/support (click "technical help")
Posted Jun 15, 2016 - 08:07 PDT
This incident affected: The LexBlog Platform (LexBlog Platform 1) and Premier Managed Platform, Support Center.