LexBlog Phones Intermittently Out of Service
Incident Report for LexBlog
Resolved
This incident has been resolved.
Posted Mar 17, 2016 - 12:50 PDT
Monitoring
We have rebooted our phone system which we believe has resolved the issue.

We will continue to monitor member reports to determine if we continue to have issues. If ever you are unable to reach our team at our 800-913-0988 number, please contact us by ticket ( http://www.lexblog.com/support/#help ) or email ( success@lexblog.com ).

Thank you!
Posted Mar 17, 2016 - 10:00 PDT
Investigating
Our phone system is currently experiencing intermittent call issues, as reported by members not being able to get through to our team.

While we work to restore service, if you are unable to get through to our team, please contact us by submitting a ticket at http://www.lexblog.com/support/#help

Thank you!
Posted Mar 17, 2016 - 09:37 PDT