LexBlog Support Ticket System and Help Center currently experiencing outages
Incident Report for LexBlog
Resolved
Zendesk has resolved the issue affecting our help center and ticket system, and we are able to receive and respond to requests normally.
Posted 9 months ago. Mar 15, 2017 - 17:11 PDT
Identified
Identified - We are aware that Zendesk, our help center and ticket system, is currently experiencing outages on all components.

As a result, we may be unable to provide updates on tickets and members may be unable to access help center articles. Zendesk is aware of this issue and is currently working to resolve it.

If you are a member seeking assistance, please call us at 800-913-0988 while we await updates.
Posted 9 months ago. Mar 15, 2017 - 12:58 PDT
This incident affected: Help Center.