Delayed Email Notifications
Incident Report for LexBlog
Resolved
We've learned MailChimp has restored normal service and is working on sending out emails that were caught up in the delay.

If you have a question or concern about a particular email notification for your blog(s), please let you account manager know.
Posted Oct 28, 2015 - 15:04 PDT
Identified
We are aware of an issue impacting MailChimp, which provides subscriber email notifications to most blogs on The LexBlog Platform powered by WordPress, LexBlog Premier Managed Platform and select blogs on legacy platforms.

As a result, email notifications may be delivered at a delayed time until MailChimp fully addresses the cause.

As we learn more about this issue, we will post updates here.
Posted Oct 28, 2015 - 12:13 PDT