Support requests via email delayed
Incident Report for LexBlog
Resolved
Our support system is receiving email normally again, and messages sent during the incident have been received.
Posted 3 months ago. Feb 28, 2017 - 21:30 PST
Identified
Our support system service provider is having an incident preventing support requests from being created via email. As a result, we are not able to view new requests or updates to existing requests, and our responses will be delayed until after this issue is resolved.

If you need assistance, please call our Success team at 800-913-0988, or open a request via the forms at https://support.lexblog.com/hc/en-us/requests/new or the LexBlog > Support Center menu item in your blog dashboard.
Posted 3 months ago. Feb 28, 2017 - 12:46 PST
This incident affected: The LexBlog Platform, LexBlog Premier Managed Platform, and Help Center (LexBlog Knowledge Base and Support Community).