LexBlog Phone and Internet Currently out of Service
Incident Report for LexBlog
Resolved
LexBlog internet and phone service have been restored. This issue is resolved.
Posted 2 months ago. Apr 14, 2017 - 17:10 PDT
Investigating
Our phone and internet are currently out of order at LexBlog Seattle headquarters.

Note: There is no impact to blog service or availability as a result of this incident.

While we work to restore service, please contact us via our ticketing form at LexBlog.com/support (click "Submit a Support Request").
Posted 2 months ago. Apr 14, 2017 - 10:01 PDT
This incident affected: The LexBlog Platform, LexBlog Premier Managed Platform, Help Center (LexBlog Knowledge Base and Support Community), Movable Type 4 (legacy LexBlog platform), and Movable Type 3 (legacy LexBlog platform).