Some WordPress sites loading slowly
Incident Report for LexBlog
Resolved
We have corrected the server slowdown that caused some sites to load slowly or fail to load. All sites should be loading normally now. If you still experience a site performing slow or offline, perform a hard refresh (CTRL+R) to restore your site. 

As always, we will continue to monitor sites and our overall server health and will immediately act in the event of a future incident.
Posted Oct 10, 2014 - 09:16 PDT
Investigating
We're investigating why some sites are currently loading slowly or failing to load on our WordPress platform and are working to restore normal service.
Posted Oct 10, 2014 - 08:37 PDT
This incident affected: The LexBlog Platform (LexBlog Platform 1).