Email newsletter delivery issue on all platforms

Incident Report for LexBlog

Resolved

This incident has been resolved and all functionality restored. Some customers may notice their scheduled newsletter was delivered up to two hours past their normal delivery time.
Posted Mar 04, 2020 - 13:55 PST

Monitoring

Our upstream email service provider has resolved the issue and email functionality is restored. We are continuing to monitor the situation to verify there are no further issues.
Posted Mar 04, 2020 - 09:42 PST

Identified

Due to an issue with an upstream service provider, all platforms are having problems delivering email newsletters.

As we learn more and work to restore normal performance, we will post updates here.
Posted Mar 04, 2020 - 07:37 PST
This incident affected: The LexBlog Platform (LexBlog Platform 1, LexBlog Platform 2, LexBlog Platform 3) and Premier Managed Platform.