Long-Running Maintenance-Related Downtime

Incident Report for LexBlog

Resolved

This incident has been resolved. We are conducting an after-action investigation.
Posted Jun 04, 2026 - 08:44 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 04:53 PDT

Investigating

We are working with our cloud-hosting vendor to determine the cause for a long-running maintenance window that is causing 404 errors on many sites.
Posted Jun 04, 2026 - 04:28 PDT
This incident affected: The LexBlog Platform (LexBlog Platform 1, LexBlog Platform 3, LexBlog Platform 4) and LexBlog.com.