LexBlog phones are temporarily down
Incident Report for LexBlog
Resolved
LexBlog phones are back up and running. Thanks for your patience!
Posted Sep 02, 2014 - 16:17 PDT
Investigating
Our phones are temporarily out of order. We're working to get them back online. In the meantime, please email your account manager directly or email support@lexblog.com if you need help.
Posted Sep 02, 2014 - 15:22 PDT
This incident affected: The LexBlog Platform (LexBlog Platform 1) and Support Center.