Increased volume of contact form spam emails
Incident Report for LexBlog
Resolved
The contact form spam incident has been resolved.
Posted Jul 18, 2022 - 12:27 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 18, 2022 - 07:10 PDT
Monitoring
A fix has been implementing and we are monitoring the results.
Posted Jul 18, 2022 - 07:10 PDT
Update
One point of clarification:

Some customers have reached out with the concern that some sort of security vulnerability has occurred. That is not the case at all. While it is a nuisance, and an important problem for us to address, there is no security vulnerability or penetration associated with this incident.

The unfortunate fact is that every contact form on the internet is constantly under a barrage of spam submissions. We have several layers in place to prevent these attempts from even getting started. Inevitably, some percentage of those spam attempts will succeed in creating a form submission. In that case, we have several layers in place to prevent the spam form submissions from actually generating an outbound email. At the moment, we're experiencing a lapse in that final layer of protection.

We expect that final layer of protection against spam emails to be restored on Monday.
Posted Jul 16, 2022 - 10:51 PDT
Identified
Some blogs on our platform are experiencing an increased volume of spam submissions to their contact form. We have identified a solution and are expecting it to be implemented across our entire platform not later than close of business on Monday, July 18.

In the meantime, we do have the capability to apply a patch to specific blogs at a higher priority. If you are experiencing this problem and would like an expedited solution, please feel free to contact our support team ( https://support.lexblog.com/hc/en-us/requests/new ). They will be able to work through those priority inquiries at the start of the business day on Monday.
Posted Jul 16, 2022 - 10:41 PDT
This incident affected: The LexBlog Platform (LexBlog Platform 1, LexBlog Platform 2, LexBlog Platform 3, LexBlog Platform 4) and Premier Managed Platform, Support Center, LexBlog.com.