Reset your LexBlog password as precaution due to Cloudflare leak
Incident Report for LexBlog
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 28, 2017 - 10:53 PST
Monitoring
We recommend that you reset your LexBlog password to protect your account due to a security incident with one of our service providers.

LexBlog uses the Cloudflare content delivery network to enhance the stability, speed and security of your blogging platform. Yesterday Cloudflare disclosed (http://bit.ly/2lQxofE) a bug that randomly exposed private information on 0.00003% of visits to the more than 5 million domains handled by its service from Feb. 13-18. Before disclosing the leak, Cloudflare fixed the bug and worked with companies like Google to clear cached instances of leaked data.

Cloudflare has identified 150 domains where leaked information was found cached, and LexBlog customer domains are not among them. But as a precaution, we recommend resetting your LexBlog password as well as your login information for any service that uses Cloudflare (http://bit.ly/2lQwakz).

Incidents like these are a good time to strengthen your passwords across your accounts. We recommend that you:

- Use unique passwords for each account with mixed-case letters, numbers and special characters
- Manage passwords with a secure password manager or tool provided by your firm
- Activate multi-factor authentication methods whenever possible
- Periodically reset passwords, especially after major data breaches or leaks

If you are a blog administrator who manages publishing on behalf of others, now is a good time to also change the user role (http://bit.ly/2lELv5c) of any users who don't log in to the platform to the Contributor role.

For Premier Managed Platform administrators, you can manage all of your users from your network dashboard (http://bit.ly/2lDve1Q) and require periodic password resets (http://bit.ly/2l8XIx4) or two-factor authentication (http://bit.ly/2lEtWSY).

To reset your own password, log in at yourlexblogdomain.com/wp-admin/profile.php and click the Generate Password button, or follow these steps (http://bit.ly/2mgrbtT) to change another user's password if you are a blog editor or administrator.

Please contact our Customer Success Team at success@lexblog.com or 800-913-0988 if you have any questions.
Posted 8 months ago. Feb 24, 2017 - 15:09 PST