LexBlog Website and Ticket Form currently out of service
Incident Report for LexBlog
Resolved
Service has been restored to our website, including our support pages and ticket form.
Posted Feb 17, 2016 - 16:30 PST
Identified
Our website is currently experiencing a disruption of service, impacting our customer request/ticketing form.

While we work to restore service, if you need to contact our team, please email success@lexblog.com or 800-913-0988. Our business hours are M-F 8:00 a.m. - 5:00 p.m. Pacific.

If during this interruption you believe your site is experiencing an outage, please email success@lexblog.com with "Site Outage" in the subject line. Technical response for site outages is available 24/7.
Posted Feb 17, 2016 - 16:27 PST
This incident affected: The LexBlog Platform (LexBlog Platform 1) and Premier Managed Platform, Support Center.