LexBlog Phone and Internet currently out of service
Incident Report for LexBlog
Resolved
Our Seattle power utility has restored power downtown and the LexBlog phone system service is restored. However, due to the relocation of our team members, we are still best reachable today via email (success@lexblog.com).

Tomorrow, phone coverage will return to normal.
Posted May 25, 2016 - 12:41 PDT
Identified
All LexBlog office communications are currently out of order due to a massive power outage in downtown Seattle: https://twitter.com/SEACityLight/status/735542529857228800

We are currently working to relocate team members to continue to provide service today via our ticketing request system.

To reach a member of our team, please email success@lexblog.com. Response times may be delayed due to this unforeseen event.

As we learn more, we will keep members posted.
Posted May 25, 2016 - 12:00 PDT
This incident affected: The LexBlog Platform (LexBlog Platform 1) and Premier Managed Platform, Support Center.